Articles of macos rubygems

Installazione MySQL: ERRORE: imansible creare l’estensione nativa gem

Sto cercando di installare MySQL all’ultima versione a causa di qualche installazione che non va in qualche punto lungo la linea. Eseguo il comando gem install mysql e ricevo quanto segue: Creazione di estensioni native. Questo potrebbe richiedere del tempo … ERRORE: errore durante l’installazione di mysql: ERRORE: imansible creare l’estensione nativa gem. /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb […]

homebrew non funziona su OSX

Ottenere questo errore quando eseguo il comando brew sul terminale. Hai bisogno di aiuto per risolvere. /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require’: cannot load such file — utils/popen (LoadError) from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require’ from /usr/local/Library/Homebrew/utils.rb:6:in `’ from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require’ from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require’ from /usr/local/Library/Homebrew/global.rb:9:in `’ from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require’ from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require’ from /usr/local/Library/brew.rb:16:in `’ ecco le mie impostazioni di gemme […]

Imansible installare le gemme su OS X “El Capitan”

Non sono in grado di installare ed eseguire fakes3 gem su El Capitan Beta 5. Provai: sudo gem install fakes3 ERROR: While executing gem … (Errno::EPERM) Operation not permitted – /usr/bin/fakes3 Poi ho provato a farlo in modo cocoapods. Ha funzionato per i cocoapodi ma non per i falsi3. mkdir -p $HOME/Software/ruby export GEM_HOME=$HOME/Software/ruby gem […]

Installare gem o aggiornare RubyGems fallisce con l’errore delle autorizzazioni

Cercando di installare una gem ( gem install mygem ) o aggiornare RubyGems ( gem update –system ) fallisce con questo errore: ERRORE: durante l’esecuzione di gem … (Gem :: FilePermissionError) Non hai i permessi di scrittura per la directory /Library/Ruby/Gems/2.0.0. Qualcuno ha idea di come risolvere questo?

Installazione di Ruby Gem su Javer non riuscito su Mavericks e Xcode 5.1 – argomento sconosciuto: ‘-multiply_definedsuppress’

Stavo cercando di eseguire gem install json e ho ottenuto il seguente errore Gem::Ext::BuildError: ERROR: Failed to build gem native extension. /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby extconf.rb creating Makefile make “DESTDIR=” clean make “DESTDIR=” compiling generator.c linking shared-object json/ext/generator.bundle clang: error: unknown argument: ‘-multiply_definedsuppress’ [-Wunused-command-line-argument-hard-error-in-future] clang: note: this will be a hard error (cannot be downgraded to a warning) […]