Articles of homebrew

Comprendere le dipendenze homebrew e solo Keg

Recentemente ho iniziato a usare homebrew e sono un po ‘confuso su cosa succede quando produco qualcosa nel mio sistema, ma le sue dipendenze fermentate sono solo keg, il che significa che sono collegate sotto /usr/local . Ad esempio, installo vips (una libreria di elaborazione delle immagini). Una delle sue molte dipendenze è pixman. Pixman […]

Ottenere un errore “cattivo interprete” quando si usa la birra

Sto ricevendo questo errore quando provo a eseguire un comando brew. Holger-Sindbaeks-MacBook-Air:~ holgersindbaek$ brew help -bash: /usr/local/bin/brew: /usr/bin/ruby: bad interpreter: No such file or directory Non ho assolutamente idea su come risolvere questo problema e ho cercato per molto tempo senza una risposta.

OSX – Sostituire gcc versione 4.2.1 con 4.9 installato tramite Homebrew

Questo mi ha tormentato per un po ‘ora. Sto cercando di compilare un enorme file C ++ (so che funziona come funziona bene sul mio computer Arch Linux al lavoro). Quando ho controllato la mia versione di GCC sul mio Mac, restituisce quanto segue Configured with: –prefix=/Applications/Xcode.app/Contents/Developer/usr –with-gxx-include-dir=/usr/include/c++/4.2.1 Apple LLVM version 6.0 (clang-600.0.57) (based on […]

Come ottenere Ruby / Homebrew / RVM per lavorare su Yosemite?

Dopo aver installato Yosemite, non sono stato in grado di eseguire brew o ruby. Stavo ricevendo questo errore sull’aggiornamento di Brew: /usr/local/bin/brew: /usr/local/Library/brew.rb: /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby: bad interpreter: No such file or directory /usr/local/bin/brew: line 23: /usr/local/Library/brew.rb: Undefined error: 0 ottenendo questo errore su irb: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/fileutils.rb:245:in mkdir’: Permission denied – /Library/Ruby/Gems/2.0.0/extensions/universal-darwin-14 (Errno::EACCES) from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/fileutils.rb:245:infu_mkdir’ from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/fileutils.rb:219:in block […]

Qual è il modo suggerito per installare brew, node.js, io.js, nvm, npm su OS X?

Sto cercando di usare homebrew il più ansible. Qual è il modo suggerito per installare quanto segue su OS X? node.js io.js NVM npm e si spera che supporti lo sviluppo per: ionico ngCordova

Octave-Gnuplot-AquaTerm error: set terminal aqua enhanced title “Figura 1” … tipo di terminale sconosciuto “

Ho installato Octave e gnuplot tramite Homebrew e scaricato AquaTerm.dmg. Quando provo a tracciare, ottengo il seguente messaggio: octave:4> plot(x,y) gnuplot> set terminal aqua enhanced title “Figure 1” font “*,6” ^ `line 0: unknown or ambiguous terminal type; type just ‘set terminal’ for a list` In un terminale di set terminal bash, set Terminal , […]

Homebrew: installa la nuova formula php72-imagick

Ho bisogno di installare il modulo imagick sul mio php 7.2 io vedo brew search php72 ==> Searching local taps… ==> Searching taps on GitHub… ==> Searching blacklisted, migrated and deleted formulae… No formula found for “php72”. Closed pull requests: … php72-imagick 3.4.3 (new formula) (https://github.com/Homebrew/homebrew-php/pull/4267) Come posso farlo? Inoltre ho bisogno di supporto per […]

Come posso passare a Ruby 1.9.3 installato usando Homebrew?

Ho installato Ruby 1.9.3 usando l’ hombrew brew install ruby Ma il valore predefinito 1.8.7 è ancora usato. Come posso passare a OSX per usare 1.9.3 come ruby ​​di default?

Server PDFtk su OS X 10.11

PDFTK server PDFTK su OSX pre 10.11 da oltre un anno senza problemi durante l’esecuzione di comandi sulla riga di comando. Dopo aver installato OSX 10.11 beta, non posso più eseguire alcun PDFTK Server sulla riga di comando. Non genera alcun errore, tutti i comandi che cerco di eseguire vengono semplicemente bloccati indefinitamente. Ho installato […]

Installazione di Nokogiri su OSX 10.10 Yosemite

Di recente ho eseguito l’upgrade alla versione 10.10 di Yosemite, ma ho problemi a installare Nokogiri. Sto usando RVM e Ruby 1.9.3. Ho seguito anche i passaggi qui e ho provato a seguire le istruzioni sulla homepage di Nokogiri. Ho installato libxml2 (2.9.1) e libxslt (1.1.28) tramite homebrew, e ho provato a utilizzare gli strumenti […]