Articles of android studio

Condivisione di quadro tra moduli di App Engine

Sto migrando da Eclipse ad Android Studio e ho un’app Android connessa ad AppEngine. Ho diviso il lato server in due moduli (modulo predefinito per endpoint e richieste utente) e il modulo “admin” per cose di backend. Ora entrambi questi moduli devono usare le Entità. (Di solito il modulo back-end è responsabile del salvataggio di […]

Android Studio non si avvia, non funziona dicendo componenti non installati

Ho installato la versione più recente di Android Studio da Google. Dopo averlo avviato, tenta di scaricare alcuni pacchetti. Dopo un po ‘mostra il seguente errore. I seguenti componenti dell’SDK non sono stati installati: extra-android-m2repository, strumenti, addon-google_apis-google-21, android-21, sys-img-x86-addon-google_apis-google-21, source-21, extra-google- m2repository Non è stato ansible correggere l’errore, anche se ho premuto Riprova più volte. […]

Come aggiungere una cartella di origine collegata in Android Studio?

In Eclipse posso aggiungere una cartella di origine al mio progetto Android come una “cartella di origine collegata”. Come ottengo la stessa cosa in Android Studio? O è ansible aggiungere una cartella esterna per build in gradle?

Android Studio: Plugin con id ‘Android-library’ non trovato

Ho cercato di far funzionare ActionBarSherlock e avere qualche problema. Un problema che ho riscontrato è il seguente messaggio durante il tentativo di crearlo: Plugin with id ‘android-library’ not found In particolare: D:\Projects\Android\actionbarsherlock>D:\Projects\Android\gradlew –info build Starting Build Settings evaluated using empty settings script. Projects loaded. Root project using build file ‘D:\Projects\Android\actionbarsherlock\build.gradle’. Included projects: [root project […]

Come verificare se la dipendenza gradle ha una nuova versione

In Android Studio quando uso + in numero di versione (come com.android.support:recyclerview-v7:21.+ ) ricevo l’avvertenza “Evita di utilizzare + in numeri di versione”. Quando uso un numero di versione specifico non posso sempre usare l’ultima versione. Ho molte dipendenze nel mio progetto. Come posso verificare se una dipendenza ha una versione più recente? Esiste un […]

Android Studio 3.0 – Nessun server per servire la richiesta

Dopo l’installazione pulita di Android Studio ottengo sempre l’errore Errore: java.util.concurrent.ExecutionException: java.lang.RuntimeException: nessun server per servire la richiesta. Controlla i registri per i dettagli. e Errore: esecuzione non riuscita per l’attività ‘: Applicazione: mergeDebugResources’. Errore: java.util.concurrent.ExecutionException: java.lang.RuntimeException: nessun server per servire la richiesta. Controlla i registri per i dettagli. Java è aggiornato e il percorso […]

gradle dietro proxy in Android Studio 1.3

Ho appena aggiornato Android Studio alla versione creata il 28 luglio 2015. Le impostazioni del proxy hanno smesso di funzionare. Li ho configurati nelle preferenze AS e nel progetto gradle.properties come questo: systemProp.http.proxyHost=some.proxy.adress.com systemProp.http.proxyPort=3128 Eppure la generazione gradle fallisce suggerendo che dovrei configurare il proxy in entrambe le proprietà graddle o IDE. Errore: connessione scaduta: […]

buildTypes non può essere applicato a groovy.lang.Closure

Sto ricevendo questo avviso nel mio file gradle del progetto: Attenzione: (16, 5) ‘buildTypes’ non può essere applicato a ‘(groovy.lang.Closure )’ La mia sezione buildTypes è: buildTypes { debug { debuggable true } release { minifyEnabled true proguardFiles getDefaultProguardFile(‘proguard-android.txt’), ‘proguard-project.txt’ } } Attualmente sto usando Android Studio 1.1.0, compileSdkVersion 22, buildToolsVersion 22.0.0, e targetSdkVersion 22. […]

Lint: come ignorare errori ” non tradotto in “?

Non riesco a compilare / eseguire il debug della nostra app per Android, perché i file di localizzazione non sono ancora perfetti. Lo strumento di convalida del mio IDE Lint crea errori dicendo: newCardsOrderVals non è tradotto in ar, bg, ca, cs Compilare / installare / eseguire con Ant funziona bene, ma mi piacerebbe usare […]

Errore: java.util.zip.ZipException: voce duplicata

Sto cercando di aggiungere una libreria al mio progetto, in questo momento il mio attuale build.gradle è: apply plugin: ‘com.android.application’ android { compileSdkVersion 21 buildToolsVersion “21.1.2” repositories { mavenCentral() } defaultConfig { applicationId “com.example.guycohen.cheaters” minSdkVersion 11 targetSdkVersion 21 versionCode 1 versionName “1.0” // Enabling multidex support. multiDexEnabled true } buildTypes { release { minifyEnabled false […]