Imansible creare l’estensione nativa gem – Installazione di Rails

Ho installato Ruby on Rails in base alle istruzioni della class online di edX.

Ecco una lista di comandi del terminale e, se del caso, uscita corrispondente:

$ sudo apt-get install ruby1.9.1 

installazione avvenuta con successo

 $ wget http://production.cf.rubygems.org/rubygems/rubygems-1.8.24.tgz $ tar zxvf ruby-1.8.24.tgz $ cd ruby-1..8.24 $ sudo ruby setup.rb RubyGems 1.8.24 installed == 1.8.24 / 2012-04-27 * 1 bug fix: * Install the .pem files properly. Fixes #320 * Remove OpenSSL dependency from the http code path ------------------------------------------------------------------------------ RubyGems installed the following executables: /usr/bin/gem1.9.1 

Fino a qui, tutto sembrava a posto, ma ho provato a installare i binari e ho fallito:

 $ sudo gem install rails Fetching: i18n-0.6.1.gem (100%) Fetching: multi_json-1.3.6.gem (100%) Fetching: activesupport-3.2.8.gem (100%) Fetching: builder-3.0.3.gem (100%) Fetching: activemodel-3.2.8.gem (100%) Fetching: rack-1.4.1.gem (100%) Fetching: rack-cache-1.2.gem (100%) Fetching: rack-test-0.6.1.gem (100%) Fetching: journey-1.0.4.gem (100%) Fetching: hike-1.2.1.gem (100%) Fetching: tilt-1.3.3.gem (100%) Fetching: sprockets-2.1.3.gem (100%) Fetching: erubis-2.7.0.gem (100%) Fetching: actionpack-3.2.8.gem (100%) Fetching: arel-3.0.2.gem (100%) Fetching: tzinfo-0.3.33.gem (100%) Fetching: activerecord-3.2.8.gem (100%) Fetching: activeresource-3.2.8.gem (100%) Fetching: mime-types-1.19.gem (100%) Fetching: polyglot-0.3.3.gem (100%) Fetching: treetop-1.4.10.gem (100%) Fetching: mail-2.4.4.gem (100%) Fetching: actionmailer-3.2.8.gem (100%) Fetching: rake-0.9.2.2.gem (100%) Fetching: rack-ssl-1.3.2.gem (100%) Fetching: thor-0.16.0.gem (100%) Fetching: json-1.7.5.gem (100%) Building native extensions. This could take a while... ERROR: Error installing rails: ERROR: Failed to build gem native extension. /usr/bin/ruby1.9.1 extconf.rb /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- mkmf (LoadError) from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require' from extconf.rb:1:in `' Gem files will remain installed in /usr/lib/ruby/gems/1.9.1/gems/json-1.7.5 for inspection. Results logged to /usr/lib/ruby/gems/1.9.1/gems/json-1.7.5/ext/json/ext/generator/gem_make.out 

mkmf fa parte del pacchetto ruby1.9.1-dev . Questo pacchetto contiene i file di intestazione necessari per le librerie di estensioni per Ruby 1.9.1. Devi installare il pacchetto ruby1.9.1-dev facendo:

 sudo apt-get install ruby1.9.1-dev 

Quindi puoi installare Rails normalmente.

Generalmente è più facile fare semplicemente:

 sudo apt-get install ruby-dev 

La risposta suggerita funziona solo per alcune versioni di ruby. Alcuni commentatori suggeriscono di usare ruby-dev; neanche quello ha funzionato per me.

 sudo apt-get install ruby-all-dev 

ha funzionato per me

 sudo apt-get install ruby-dev 

ha funzionato per me