system.data.sqlite .net 4

Esiste una versione .Net 4 di System.Data.SQLite?

Al momento ricevo questo errore:

L’assemblaggio in modalità mista è costruito contro la versione ‘v2.0.50727’ del runtime e non può essere caricato nel runtime 4.0 senza ulteriori informazioni di configurazione.

Quali sono le “informazioni di configurazione aggiuntive” necessarie o in alternativa esiste un’altra versione che posso utilizzare?

     

Secondo i forum di PhxSoftware :

Al momento non è in cima alla mia lista di priorità. Quando VS2010 si avvicina al rilascio, aggiornerò la libreria per lavorarci.

Sebbene il messaggio sia stato pubblicato nell’ottobre 2009, ci sono alcune soluzioni alternative .

Inoltre sembra esserci una versione aggiornata (temporanea) appositamente per .NET 4:

Sì, c’è ora.

http://system.data.sqlite.org/index.html/doc/trunk/www/downloads.wiki

E puoi anche usare NuGet per installarlo. Con nuget, è facile scegliere tra x86 / x64 / entrambi, http://www.nuget.org/packages?q=system.data.sqlite .