L’installazione di Nokogiri fallisce -libxml2 manca

Ho sempre lavorato sui problemi di installazione di Nokogiri seguendo la documentazione del tutorial ” Installazione di Nokogiri “.

Ma questa volta, anche dopo aver installato tutte le dipendenze, Nokogiri non è stato installato. Ottengo il seguente errore:

libxml2 is missing. please visit  

Ho provato a installarlo specificando le directory libxml2 e libxslt:

 sudo gem install nokogiri -- --with-xml2-include=/usr/include/libxml2 --with-xml2-lib=/usr/lib --with-xslt-dir=/usr/ 

ma ha restituito lo stesso errore.

Ho seguito tutti gli altri articoli relativi allo Stack Overflow e nessuno mi ha aiutato. Qualcuno ha una soluzione?