Perché stiamo installando gemme Ruby 1.9.2 / 1.9.3 in una cartella 1.9.1?

Questo accade perché la directory di installazione di Gem usata dal comando gem , vista quando si usa gem env , è impostata su qualcosa di simile:

 /lib/ruby/gems/1.9.1 

La mia domanda è perché?

Non si dovrebbe chiamare la cartella:

 /lib/ruby/gems/1.9.x 

o

 /lib/ruby/gems/1.9 

altrimenti non potrebbe essercene uno per versione di Ruby, come:

 c:/ruby191/lib/ruby/gems/1.9.1 c:/ruby192/lib/ruby/gems/1.9.2 c:/ruby193/lib/ruby/gems/1.9.3 

Non è un problema critico, lo so, mi stavo solo chiedendo.