Imansible avviare iOS 8 Simulator

Ciao ho appena aggiornato il mio Xcode a 6.0.1 dal Mac App Store, e la mia versione del sistema operativo è OS X 10.9.5. Il problema è che il simulatore iOS 8 non si sta caricando, ma il simulatore iOS 7 funziona correttamente.

Ogni volta che provo ad avviare un dispositivo di simulazione iOS 8, viene visualizzato un messaggio di errore: “Imansible avviare iOS Simulator”

La causa principale di questo errore è che DYLD_INSERT_LIBRARIES è impostato. Suggerisco di disinserire DYLD_INSERT_LIBRARIES (probabilmente in /etc/launchd.conf) o altrimenti disinstallare il prodotto che lo ha impostato, e quindi riavviare.

OS X Yosemite ha una modifica del software per gestire questa situazione, quindi se hai bisogno del prodotto che stava impostando DYLD_INSERT_LIBRARIES, ti suggerisco di aggiornare a OS X Yosemite per il tuo sviluppo.

Vai in Finestra-> Dispositivi. Trova il simulatore che non funziona, fai clic con il tasto destro e cancellalo. Quindi fai clic sul pulsante “+” in basso e puoi aggiungerlo nuovamente.

Ho dovuto cancellare alcuni di loro, e questo richiede solo un minuto.