Come si può risolvere UNMET PEER DIPENDENCY?

Sono su Windows 10, Node versione 5.6.0 e npm versione 3.6.0. Cercando di installare angularmaterial e mdi nella mia cartella di lavoro. npm install angular-material mdi mi dà i seguenti messaggi di errore:

+ – [email protected] 1.5.0

+ – UNMET PEER DEPENDENCY [email protected]^1.5.0

+ – UNMET PEER DEPENDENCY [email protected]^1.5.0

+ – [email protected]

    + – UNMET PEER DEPENDENCY [email protected]^1.5.0 `- [email protected]

    npm WARN enoent ENOENT: nessun file o directory di questo tipo, aprire ‘C: \ Users \ xxxxx \ Desktop \ ngClassifieds \ package.json’

    npm WARN [email protected] richiede un peer di [email protected]^1.5.0 ma nessuno è stato installato.

    npm WARN [email protected] richiede un peer di [email protected]^1.5.0 ma nessuno è stato installato.

    npm WARN [email protected] richiede un peer di [email protected]^1.5.0 ma nessuno è stato installato.

    Come posso risolvere questo problema per ottenere materiale angular e mdi installato?

    npm non installa più le dipendenze peer, quindi è necessario installarle manualmente, basta eseguire l’ npm install sui deps necessari, quindi provare a installare di nuovo quella principale.


    Rispondi al commento:

    è giusto in quel messaggio, dice che ti stai perdendo

     UNMET PEER DEPENDENCY [email protected]^1.5.0 +-- UNMET PEER DEPENDENCY [email protected]^1.5.0 +-- [email protected] + UNMET PEER DEPENDENCY [email protected]^1.5.0 `-- [email protected]` 

    Quindi devi npm install angular angular-animate angular-aria angular-material angular-messages mdi

    UNMET PEER DEPENDENCY errore UNMET PEER DEPENDENCY viene generato quando le dipendenze di uno o più moduli specificati nel file package.json non vengono soddisfatte. Controllare attentamente gli avvertimenti e aggiornare il file package.json con le versioni corrette delle dipendenze.

    Quindi corri

     rm -rf node_modules/ npm cache clean npm install 

    Questo installerà correttamente tutte le dipendenze richieste.

    Nel mio caso tutte le dipendenze erano già lì. Si prega di aggiornare NPM in quel caso in quanto potrebbe essere stato arrestato. Ha risolto il mio problema. npm install -g npm

    npm-install-peers ha funzionato per me.

     npm install -g npm-install-peers 

    Una delle cause più probabili di questo errore potrebbe essere la definizione della versione precedente nel pacchetto package.json. Per risolvere questo problema, cambia le versioni in package.json in modo che corrispondano a quelle di cui i npm si lamentano.

    Una volta fatto, esegui l’installazione di npm e voilà !!.

    Ok, quindi ho lottato a lungo cercando di capirlo. Ecco l’opzione nucleare , per quando hai esaurito tutti gli altri modi ..

    Quando hai finito, e funziona ancora, importa il tuo codice reale in questo nuovo progetto. Correggere eventuali errori di compilazione la versione più recente delle cause angolari.

    Ecco cosa ha fatto per me .. 1 ora di rielaborazione contro 6 ore di tentativi di capire che wtf era sbagliato .. vorrei averlo fatto in questo modo per iniziare ..

    Oggi disponibile Angular 2 rc.7 , e ho avuto un problema simile con [email protected] UNMET PEER DEPENDENCY.

    Se tu, come me, hai semplicemente sostituito @angular/...rc.6 in @angular/...rc.7 – non è abbastanza. Perché, ad esempio, @angular/router rc.6 @angular/router non ha la versione rc.6 .

    In questo caso, rivedere il pacchetto package.json in Avvio rapido

    La risposta data non funzionerà sempre. Se non risolve il problema. Assicurati di utilizzare anche il simbolo corretto nel package.json . Questo è molto importante per risolvere questo mal di testa. Per esempio:

     warning " > @angular/[email protected]" has incorrect peer dependency "[email protected]>=2.4.2 <2.7". warning " > [email protected]" has incorrect peer dependency "[email protected]>=2.4.2 <2.6". 

    Quindi il mio typescript deve essere compreso tra 2.4.2 e 2.6, giusto?

    Così ho cambiato la mia libreria di typescript usando "typescript": "^2.7" per usare "typescript": "^2.5" . Sembra corretto?

    Sbagliato.

    Il ^ significa che stai bene con npm usando "typescript": "2.5" o "2.6" o "2.7" ecc ...

    Se vuoi sapere che cosa significano ^ e ~ significa: Qual è la differenza tra tilde (~) e caret (^) in package.json?

    Inoltre devi assicurarti che il pacchetto esista. Forse non c'è un "typescript": "2.5.9" cerca i numeri del pacchetto. Per essere davvero al sicuro basta rimuovere il ~ o il ^ se non vuoi leggere cosa significano.

    puoi risolvere installando le dipendenze UNMET a livello globale.

    esempio: npm install -g @ angular / common @ 4.4.6

    installarli uno per uno. ha funzionato per me.