Avvia Binario non riuscito non trovato Eclipse per C in Windows

Ho installato il plug-in Eclipse CDT e anche i seguenti pacchetti:

  1. MinSys
  2. MinGW

Ho anche aggiunto dei percorsi al loro bin nella variabile d’ambiente PATH. Anche in questo caso non riesco a compilare ed eseguire alcun programma di esempio in Eclipse.
Come posso risolvere questo? Grazie per la tua preoccupazione.

Ho persino affrontato questo errore e ho cercato molto per risolvere il problema. Fortunatamente, l’ho capito da solo.

Le seguenti sono le cose che ti servono per assicurarti che siano impostate:

  1. Finestra> Preferenze> C / C ++> Nuova procedura guidata progetto CDT> Progetto Makefile> Parser Parser

    a) Impostarlo su PE Windows Parser se si è su Windows.

    b) Impostalo su Cygwin PE Parser se stai usando Cygwin

    c) Impostalo su parser Elf se stai usando Ubuntu

  2. Finestra> Preferenze> C / C ++> Build> Ambiente

    Ora fai clic su “seleziona” e seleziona la variabile “Percorso” in modo da aggiungere le variabili del percorso in Eclipse.

Ora è tutto fatto!

Tutto quello che devi fare è scrivere un programma di test e premere Ctrl + B (Crea tutto, c’è un pulsante sulla barra dei menu) e dopo di ciò fai clic su “Esegui”.

Dopo che tutta la configurazione è terminata. Vai al project --> build all eclipse project --> build all o Ctrl + B quindi eclipse crea automaticamente i binari e altre cose ora esegui il tuo progetto

  1. Aprire le proprietà del progetto (fare clic con il tasto destro del mouse sul progetto, selezionare Proprietà nel menu)
  2. C / C ++ Build -> Impostazioni
  3. Fare clic sulla scheda Binary Parsers e selezionare PE Windows Parser

Nel mio caso

  1. Ho appena salvato il programma. Premi Ctrl + B per costruirlo.
  2. Aggiorna.
  3. Quindi esegui il programma.

Ora puoi vedere che funzionerà bene.

  1. Costruire
  2. Aggiorna il progetto. Una nuova cartella denominata Binaries verrà ora visualizzata in Project Explorer.
  3. Ora corri 🙂

Questo problema è successo con me. Ho trovato il problema che l’anti-virus che sto usando considera il file binario come un cavallo di Troia e disabilita Eclipse dalla sua creazione. È necessario disabilitare la modalità di protezione automatica, quindi creare il progetto ed eseguire.

Mi è appena successo ed è stato un po ‘sciocco.
Eclipse non ha mostrato errori, ma apparentemente ce n’era uno nella finestra della console.

Ricontrolla che tutto va bene lì.

Stesso problema, ma su Mac OS su Eclipse Kepler. Risolto con la seguente configurazione

Fare clic con il tasto destro del mouse su project-> properties-> C / C ++ General-> Run / Debug Settings.

Non ho visto nessuna configurazione di avvio. Così, ho creato nuovo e inserire le seguenti voci. Problemi è il nome dell’applicazione :-). Ricorda che questo funzionerà solo per il progetto Debug, non per Release o dovrai aggiornare di nuovo l’impostazione di build. Spero che questo ti aiuti.

inserisci la descrizione dell'immagine qui

aggiungi librerie di terze parti se nel caso si stia tentando di compilare il progetto OPEN SANKORE in altri progetti, provare ad installare librerie di terze parti su Linux

  sudo apt-get install zlib1g-dev libjpeg62-dev libtiff4-dev libmng-dev libpng12-dev libdirectfb-dev libgstreamer-plugins-base0.10-dev libgstreamer0.10-dev libpulse-dev libaudio- dev libasound2-dev libfreetype6-dev libfontconfig1-dev libts-dev libcups2-dev libdbus-1-dev libglib2.0- dev libgtk2.0-dev libx11-dev libxext-dev libxcursor-dev libxfixes-dev libxrandr- dev libxrender-dev libxv-dev libxinerama-dev libxi-dev libsm-dev libssl-dev libphonon-dev libt1-dev libpaper-dev 

Ho affrontato lo stesso problema e provato i metodi sopra ma non uso e quando ho provato ad eseguire in prompt dei comandi mi ha dato l’errore “Applicazione non avviata correttamente ….” e poi ho provato con il blocco di codice che mi ha dato “Applicazione non avviata correttamente … “errore. Poi ho scaricato MinGW da http://www.equation.com/ Ha iniziato a funzionare

inserisci la descrizione dell'immagine qui

Anche io ho affrontato questo problema simile e la ragione dietro a questo problema è abbastanza semplice che il compilatore non è riuscito a ottenere il file binario del codice scritto.

Allora, dov’è il tuo errore?

La risposta è che c’è qualcosa di sbagliato nel processo di installazione di Eclipse. Sì, non l’hai installato correttamente

Ecco la soluzione

La prima cosa è che nessuno sa dove si trova il difetto nel processo di installazione, anche se non lo sai.

ed ecco il tutorial “Come installare eclipse correttamente”.

Come installare Eclipse su Windows per C e C ++ correttamente

Fidati di me dopo aver visto questo troverai il tuo errore e il file binario verrà trovato dal tuo compilatore.

Guarda questo intero video di 8 minuti, questa è solo la soluzione che ho trovato dopo 7-8 giorni di duro lavoro.

Ho avuto lo stesso numero di “binario non trovato” e ho provato tutte le soluzioni ma purtroppo non ha funzionato. Stavo provando cose e ho scoperto che quando ho cambiato la mia attuale toolchain (tasto destro del mouse su impostazioni di click del progetto-> c / c ++ build-> tool chain editor) Cross GCC su Cygwin GCC, pulisci tutto costruisci tutto e indovina un po ‘? Sono in grado di correre !!

So che questo è un vecchio post, ma ho appena avuto lo stesso problema e nulla di quello che ho trovato online funzionerebbe, né le soluzioni in questo post.

Sono riuscito a risolverlo modificando il builder predefinito da CDT Internal a GNU Make, facendo clic con il tasto destro del mouse sul progetto> Proprietà> C / C ++ Build> Tool Chain Editor> Generatore corrente> GNU Make Builder.

Spero che questo ti aiuti

Seleziona FCC e CDT come builder predefinito per il progetto. Questo potrebbe aiutarti a risolvere il problema. A proposito, ti incoraggio anche a usare il programma Geany. Funziona bene pure. È pronto per l’uso solo installare gcc su MinGW.